PlanetSquires Forums

Support Forums => Other Software and Code => Topic started by: Shawn Anderson on January 04, 2019, 03:12:53 PM

Title: not compiling
Post by: Shawn Anderson on January 04, 2019, 03:12:53 PM
I'm using FF v3.74 with PowerBasic

If I try to compile, it just ignores everything.
If I click "run", the it will run the last version of a successful compile.
It will not compile any of my projects, so I suspect FF and not code.
I tried deleting rc* and codegen* files and rebooting.

A video of what happens is here:
https://vimeo.com/user3509148/review/309524930/292daddeea (https://vimeo.com/user3509148/review/309524930/292daddeea)
Title: Re: not compiling
Post by: Paul Squires on January 04, 2019, 03:35:18 PM
Maybe try loading your CODEGEN_*_MAIN.BAS into PBEdit and try to compile it. Does it compile?
Title: Re: not compiling
Post by: Paul Squires on January 04, 2019, 03:36:22 PM
Also, where is the compiler located? Is it on the same drive as FF? Maybe FF is not finding the compiler or the generated batch file that does the compile.
Title: Re: not compiling
Post by: Shawn Anderson on January 04, 2019, 04:13:22 PM
Everything is on the same drive.

If I open CODEGEN_*_MAIN.BASin PBEDIT it can't find any of Jose's include files...
for instance

Code: [Select]
#INCLUDE ONCE "GDIPlus.inc"   
do I need to change all those to full paths or something? 

Title: Re: not compiling
Post by: Shawn Anderson on January 04, 2019, 04:39:40 PM
A while back I uninstalled FF version 3.5... I wonder if that removed something I needed?
Title: Re: not compiling
Post by: Shawn Anderson on January 04, 2019, 04:57:41 PM
I just re-installed and I'm back in business.
thanks
Title: Re: not compiling
Post by: Paul Squires on January 04, 2019, 05:39:01 PM
Perfect - that's great news  :-)