PlanetSquires Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2 3 ... 10
 1 
 on: April 08, 2020, 09:21:09 PM 
Started by Paul Squires - Last post by Paul Squires
Yes, I seem to remember that type of resource file error mentioned here before. I can't remember what the outcome of it was? Maybe that was time that we all had to ensure that we had the latest GoRc resource compiler downloaded from the author's site. Those temporary files (ie TMPE582.rc) are created during compiling. They mostly contain the references to IMAGES that exist in your project. The temporary file is then appended to the main program's resource file and then deleted.

 2 
 on: April 08, 2020, 08:15:41 PM 
Started by Paul Squires - Last post by SeaVipe
WinFBE was crashing sometime during the Compile - about 10 or so seconds into it before crashing. So I deleted "projectname_db_data.ini" and "WinFBE_VD_MAIN.bas" again, but to no avail. Next, I rebooted my machine and tried again. This time (without any modifications) it compiled but threw an error: "mnemonic Not Defined" in wfxButton. This may be because when I added the new button (which started all this) I wanted the mnemonic for the button to be "c" which was already in use by the "Cancel" button. So I changed the Cancel button mnemonic to the letter "n" and set the new button to the letter "c". This error did not show up until after I rebooted.
Now, however, I cannot replicate the errors or the crashing but still can't compile because of my old nemesis "1 Error" (the Compiler Results tab is blank). The last line of the Compile Log reads: "compiling rc: C:\WinFBE_Suite\FreeBASIC-1.07.1-gcc-5.2\bin\win64\GoRC.exe /ni /nw /o /machine X64 /fo "C:\SRC\DailyJournal\TMPE582.obj" "C:\SRC\DailyJournal\TMPE582.rc " including the 2 trailing ASCII Chr.
You may recall I've been through this before but for the life of me I can't remember what the previous fixes were. I deleted the resource file but no change. :0(
Setting any button UseMnemonics to False will throw an error pointing to this line in WinFBE_VD_MAIN.bas: "pForm->btnCancel.UseMnemonic = False". ThemeSupport is set to False for all buttons.

 3 
 on: April 08, 2020, 06:53:54 PM 
Started by Paul Squires - Last post by Paul Squires
Sounds like maybe the Form file itself is corrupted? If a Form exists in the project then it should generate a WinFBE_VD_MAIN.bas file when you compile. Not 100% sure at this point. At what point does WinFBE crash? As soon as you load the project?

 4 
 on: April 08, 2020, 04:28:02 PM 
Started by Paul Squires - Last post by SeaVipe
Hi Paul, I deleted "projectname_db_data.ini". WinFBE still crashes. "projectname_db_data.ini" does not get recreated and "WinFBE_VD_MAIN.bas" is a blank file.

 5 
 on: April 08, 2020, 03:35:40 PM 
Started by Paul Squires - Last post by Paul Squires
I have fixed the reposition in middle of screen. There were other scenarios where it was supposed to osition to middle and it was not doing so.

I will try to recreate the issue you have described. In the meantime, try deleting the "projectname_db_data.ini" that exists in the same folder as your project's .wfbe project file and then try a recompile to see if it works.

 6 
 on: April 08, 2020, 02:29:20 PM 
Started by Paul Squires - Last post by SeaVipe

:0). :)
Odd behaviour: I added a button to a form using Right/Click Copy then Paste. Positioned the Button, then selected the Click Event. Didn't save the project (at this point, I almost always Save but didn't) but did edit the Click Event by adding one line: ? "Click Event", __FUNCTION__. Clicked Compile and Run. WinFBE crashed sometime during compile. I've since removed the button and its related code but WinFBE still crashes. I've yet to delve into the raw form code.

 7 
 on: April 08, 2020, 02:06:29 PM 
Started by Paul Squires - Last post by Paul Squires
Ahhhh yes the find in files may not be centering. I'll check that. Sounds like an oversight on my part.

 8 
 on: April 07, 2020, 08:32:52 PM 
Started by Paul Squires - Last post by SeaVipe
F3 centres the find in the page only if the Find is on one page. Which is probably how you designed it.
Find In Files, Current Project places the found found on the 4th line.

 9 
 on: April 07, 2020, 08:09:54 PM 
Started by Bruce Huber - Last post by Paul Squires
Thanks Jose, I just add RegEx searching to my To Do list. I'll use your class to implement it.

 10 
 on: April 07, 2020, 08:08:05 PM 
Started by Paul Squires - Last post by Paul Squires
That's odd. Maybe I'm doing something different because I didn't notice that behaviour. Try highlighting a word and press "F3" to see if the next found found re-positions to the centre of the screen.

Pages: [1] 2 3 ... 10