PlanetSquires Forums

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: First App - out of date WinAPI - newly installed  (Read 362 times)

AlexOZ

  • Guest
First App - out of date WinAPI - newly installed
« on: January 17, 2008, 10:20:53 PM »

Hi

I'm brand new to powerbasic 8 for windows (newly installed) and evaluating FireFly. I'm getting an out of date message with WinAPI when compiling. FF sees the file date of CommCtrl.inc as 1601-01-01. In options I've set the RCC include path as C:\PBWin80\WinAPI\. The actual compile error message has Compile file not found.... #Include WinAPI...

Regards

Alex

Logged

TechSupport

  • Guest
Re: First App - out of date WinAPI - newly installed
« Reply #1 on: January 18, 2008, 08:27:36 AM »

Hi alex,

Strange problem indeed. Looks like the function that I am using to check the file date must be returning it incorrectly. It is a function that I stole from the PB Source Code forum a long, long time ago.

Code: [Select]
Function fGetFileDate(ft As FILETIME) As String
  ' function is used to check the date of the Include files.
  Local st    As SystemTime
  Local zText As Asciiz * 255
  Local Temp  As String
      ' -- Convert the file time from UTC to local time
      FileTimeToLocalFileTime ft, ft
      ' -- Convert the file time into a compatible system time
      FileTimeToSystemTime ft, st
      ' -- Create a date string using the local settings (in format YYYY/MM/DD)
      GetDateFormat %LOCALE_USER_DEFAULT, ByVal %Null, st, "yyyyMMdd", zText, 255
      Temp = zText
  Function = Temp
End Function


IncludeDate = fGetFileDate( lpFindFileData.ftLastWriteTime )
If Val(IncludeDate) < 20031027 Then
   ' print compile warning message
End If

I will disable that code and upload a new version tonight. I will post here when it is ready. Sorry for the trouble.

Just out of curiosity, what is your version of Windows? Are you running it under a virtualization environment?



Logged

TechSupport

  • Guest
Re: First App - out of date WinAPI - newly installed
« Reply #2 on: January 19, 2008, 10:01:02 AM »

Hi Alex,

Attached to this email is a new version of the FFengine.exe. Copy it to your FireFly installation directory. Hopefully it will get rid of your include file date problem. Please let me know if you still experience problems.



[attachment deleted by admin]
Logged

AlexOZ

  • Guest
Re: First App - out of date WinAPI - newly installed
« Reply #3 on: January 19, 2008, 06:32:22 PM »

Hi

Thanks for that. It removed the first problem by not checking but I still get an error message. I've attached a copy of the error message plus the options screen. By the way I'm running Windows XP Pro with Australian date/time configuration.

Regards

Alex

[attachment deleted by admin]
Logged

Jose Roca

  • Guest
Re: First App - out of date WinAPI - newly installed
« Reply #4 on: January 19, 2008, 07:35:03 PM »

 
The include path should be C:\PBWIN80\WINAPI, not C:\PBWIN80\bin.
Logged

AlexOZ

  • Guest
Re: First App - out of date WinAPI - newly installed
« Reply #5 on: January 20, 2008, 01:37:03 AM »

ouch ;D you are correct - thanks for correcting an obvious mistake.

Alex
Logged