PlanetSquires Forums

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: WinFBE - Compiler Error  (Read 300 times)

SeaVipe

  • Senior Member
  • ***
  • Posts: 251
  • Windows 10
WinFBE - Compiler Error
« on: November 20, 2019, 03:31:19 PM »


After changing some project file names and reloading the project, I'm getting the following compiler error:
Quote

compiling rc:               C:\WinFBE_Suite\FreeBASIC-1.07.1-gcc-5.2\bin\win64\GoRC.exe /ni /nw /o /machine X64 /fo "C:\SRC\CRM\TMPE9A1.obj" "C:\SRC\CRM\TMPE9A1.rc"
’žE
Including those 3 charachters on a separate line.
I've had this problem before but I can't find the solution in my notes.
Couldn't find an answer on FB forum.
Logged
Clive Richey
There is nothing government can give you that it hasn't already taken from you in the first place. Winston Churchill

Johan Klassen

  • Junior Member
  • **
  • Posts: 87
  • FF3 User
Re: WinFBE - Compiler Error
« Reply #1 on: November 20, 2019, 08:35:46 PM »

just a thought, replace gorc.exe with the latest
Logged

Paul Squires

  • Administrator
  • Guru Member
  • *****
  • Posts: 8941
  • Windows 10
    • PlanetSquires Software
Re: WinFBE - Compiler Error
« Reply #2 on: November 20, 2019, 09:50:19 PM »

I think that if you change file structures and copy existing project/form files into it then the references to images that are present in those form files are NOT updated to reflect the new folder structure. This could be the reason that the resource compile is failing. Maybe try re-selecting the images contained in your file. If this is actually the problem then I will have to put code in to warn the user that references to images are no longer valid (rather than spit out incorrect image filenames to the resource file that gets compiled).
Logged
Paul Squires
PlanetSquires Software
WinFBE Editor and Visual Designer

SeaVipe

  • Senior Member
  • ***
  • Posts: 251
  • Windows 10
Re: WinFBE - Compiler Error
« Reply #3 on: November 21, 2019, 01:50:50 PM »

Thanks, Johan, I'll do that.
Paul, I had yet to get to adding images to any forms. However, the image manager only had 1 entry (WINFBE RCDATA) which was referencing a non-existent image. (IE click on the image name and NO image appeared and NO file name was displayed.) After removing the image from the image manager I added an image to a form and now the app compiles correctly - problem solved, thanks.
« Last Edit: November 21, 2019, 01:58:08 PM by SeaVipe »
Logged
Clive Richey
There is nothing government can give you that it hasn't already taken from you in the first place. Winston Churchill