• Welcome to PlanetSquires Forums.

i'm having an "invalid defined compiler path" issue....

Started by veltesian, July 05, 2022, 08:37:35 AM

Previous topic - Next topic


yes i noticed after i just finished a small little project i started getting this error,... just before i DL'd & installed version 3.0.1,.... & now that i have 3.0.1 installed & the error still is there. can anyone possibly help me fix this ??????

Paul Squires

Hi, I assume you downloaded and installed the WinFBE Suite version rather than just the new WinFBE exe's to overwrite the existing exe's?

The new WinFBE version 3, uses a "toolchain" folder that exists off of the main WinFBE install folder. This is where the compiler toolchain will exist. The toolchain is automatically installed there if you chose to download the WinFBE Suite package.


In WinFBE, go to "File", "Preferences", "Environment Options", and select the "Compiler setup" option in the left hand list box. You should then see the list of available compiler toolchains to choose from. The default that ships with WinFBE is called "FreeBASIC-1.09.0-winlibs-gcc-9.3.0". Select that toolchain and press "OK".

You could also try reinstalling WinFBE 3 to a new fresh folder and see if that solves the problem. Maybe installing over an existing WinFBE 2 folder is causing a problem?

Paul Squires
PlanetSquires Software
WinFBE Editor and Visual Designer


actually extracting the zip to a fresh folder did the trick ... thanks paul.

btw..... nice touch on the UI     i like it much .....