• Welcome to PlanetSquires Forums.
 

i've encountered an issue with the picturebox obj.....

Started by veltesian, July 20, 2022, 10:02:52 AM

Previous topic - Next topic

veltesian

I recently tried to use the picture box to just have an image loaded when the form launches
& I seem to get the below error every time... even if I tried to preload a *.BMP - I even set the
config so that the "resource format" reads "RCDATA" & still it fails.........

I just wish I could get some help with this....

*********************************************************************************************************
Failed Compile (Errors 1  Warnings 0  [2022-07-20  08:52:08])

Command Line:
A:\WinFBE_Suite\Toolchains\FreeBASIC-1.09.0-winlibs-gcc-9.3.0\fbc64.exe -m "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\WinFBE_VD_MAIN.bas" "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\TMPC489.rc" -v -s gui -exx -w all -fpmode fast -fpu sse -arch 686 -gen gas  -x "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\GUI-0004.exe"

FreeBASIC Compiler - Version 1.09.0 (2021-12-31), built for win64 (64bit)
Copyright (C) 2004-2021 The FreeBASIC development team.
standalone
target:       win32, 686, 32bit
backend:      gas
compiling:    A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\WinFBE_VD_MAIN.bas -o A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\WinFBE_VD_MAIN.asm (main module)
assembling:   A:\WinFBE_Suite\Toolchains\FreeBASIC-1.09.0-winlibs-gcc-9.3.0\bin\win32\as.exe --32 --strip-local-absolute "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\WinFBE_VD_MAIN.asm" -o "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\WinFBE_VD_MAIN.o"
compiling rc:               A:\WinFBE_Suite\Toolchains\FreeBASIC-1.09.0-winlibs-gcc-9.3.0\bin\win32\GoRC.exe /ni /nw /o /fo "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\TMPC489.obj" "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\TMPC489.rc"
ÿþE
**********************************************************************************************************

veltesian

Also I've been curious to know how does someone build a *.rc file from scratch?
I'm not really understood how to do that. if anyone could shed light on this
i'd certainly appreciate it... perhaps that might be a means to allow a *.bmp/
*.png/*.jpg/*.gif/ETC to load more fluidly/comfortably/etc? hopefully.. ?

Bumblebee

ÿþE suggests you might have an encoding issue with your .bas file.
I vaguely remember having this issue - had something to do with mixing up a regular .bas module with a form. Form code should be UTF-16.

The picturebox should load images without issue. At design time, or via code.

I've attached an .rc template and the .xml schema it references.

Paul Squires

Try compiling by having all of your source in folders that do not contain spaces. I see that your folder seems to be "A:\WinFBE_Suite\PRJs\~~~~~GUI & stuff\"

The space after "GUI" and before "stuff" could be the problem. I had several long posts on the FreeBasic forum about compiling errors with the gcc toolchain when using long folder names with spaces AND in my experience it was normally involving the resource file.

Also, try compiling using 32 bit gas and 64 bit gcc (rather than 64 bit gas that you appear to be using). Would be interesting to see if either makes a difference.
Paul Squires
PlanetSquires Software
WinFBE Editor and Visual Designer

veltesian

#4
I have fixed the folder path name that the project is in... but still
the compiler/etc seems to still exibit this error or some error similar.
ok ... so far i've looked into a few panels to attempt fixing this issue

1. preferences/environmental options/compiler setup
  * i see the following "-exx -w all -fpmode fast -fpu sse -gen gas64 "
in this textfield just under the toolchains text area
i'm not really sure how to edit that to reflect a proper change in how it will work.

2. i pressed SHIFT + 5 which showed me this small panel (Cswitches) that is as follows...
  * there are 2 checkboxes @ the top of this panel labeled "-exx"(shows checked) & "-arch"
(shows block within it) & then below that shows a label "select switches". there are 8
options to choose from below that label:
* -gen gas
* -gen gas64
* -gen gcc
* -gen gcc -O 1
* -gen gcc -O 2   
* -gen gcc -O 3
* -gen gcc -Wc -Os
* -gen gcc -Wc -Ofast

3. inside the build config: i see several checkbox options that display each individual of
items i can add or remove from i guess the overall compiler config??? i'm not even sure
which ones to check or uncheck.....

.... unfortunately i don't really understand how to fix this issue based on instructions from your last post.
sorry for my not really understanding how to get this right...






Paul Squires

Quote from: veltesian on July 23, 2022, 06:05:32 AM1. preferences/environmental options/compiler setup
  * i see the following "-exx -w all -fpmode fast -fpu sse -gen gas64 "
in this textfield just under the toolchains text area
i'm not really sure how to edit that to reflect a proper change in how it will work.

Delete all of that text so that the textbox is now empty. (this is important. ensure it is blank)
Close that dialog.


Select "Build Configurations" by pressing F7
In the left side list select "Win64 GUI (Release)"

Ensure that the "Compiler Options" textbox on that dialog now reads:
-s gui -gen gcc

This will cause WinFBE to compile using GUI (no console output) using the GCC compiler in 64 bit mode.

The other stuff that you were doing (eg. Ctrl+5) invoked a 3rd party user tools utility that injects advanced user settings into the compile environment. 99% of the time the average user does not need to use that utility.

Paul Squires
PlanetSquires Software
WinFBE Editor and Visual Designer

veltesian

yes & yes, I got it straight now .... thanks paul ever so much for the help.
it's much appreciated :D